Not Sure If Bug Or Not...

I was customizing the look of the pagination of my search results… so I set pagerCssClass to false because I want to use my own styling and set cssFile to my style I needed to use.

This method kills the AJAX pagination and makes it post to the url.

I need to use a custom style what are my options here? Anyone else experience this? Thanks in advance.

You can’t set pagerCssClass to nothing, just set cssFile and style the .pager class.

Could you post the ajax code too ?

May jquery selector has some nessesar class

It default for the CGridView I didn’t write any custom AJAX code to show you. I guess I will just keep it and try and style around it.

Are you sure you’re setting the cssFile property on the pager? That’s what’s styling ul.yiiPager.

<?php $grid=$this->widget('zii.widgets.grid.CGridView', array(





)) ?>