(new Query())->from('table')->getOne() A setter should always return void. I would prefer for functions wtihout set prefix, that they always return the original objet itself.
Except for get*, has*, is*, to* (e.g. toString() )
Google a bit about this: found an interesting opinion, I am not sold on it, have to check it again after having slept over it.
edit: made the example code show how I wished it to be, instead of how it looks like when not.
This should be used for strict setters that does nothing but setting/getting
These should reflect exactly what they say. For example isRunning() and shouldRun() should just do that, checking whether it is already running or we are allowed even to run at that point.
Same as above, me thinks
Am fine with name that reflects what it is doing
On Route is should be getHost() really host sounds like a command to host than a getter. So is to which is I don’t know what it does from reading it. Have to consult docs (which is bad. Mehods should try to be self docmenting)