Moving website from localhost to hosting problems

I’m trying to move my website from localhost to a hosting. Everything seems to be setup, database is imported and connection in config/main.php is set correctly. But I get errors like:

Internal Server Error

The table "zCharacter" for active record class "zCharacter" cannot be found in the database.

Application log shows:

system.db.CDbCommand    |    Error in querying SQL: SHOW COLUMNS FROM `zCharacter`

exception.CDbException  |   

exception 'CDbException' with message 'The table "zCharacter" for active

record class "zCharacter" cannot be found in the database.' in


Stack trace:

#0 /home/equ/


#1 /home/equ/





#3 /home/equ/


#4 /home/equ/


#5 /home/equ/


#6 /home/equ/

CController->runActionWithFilters(Object(CInlineAction), Array)

#7 /home/equ/


#8 /home/equ/


#9 /home/equ/


#10 /home/equ/ CApplication->run()

#11 {main} REQUEST_URI=/search/results?cn=%E5%99%A2%E4%BB%AC

Main page, contacts page and login page work fine. The database structure is exactly the same, the files are also the same.

What are some possible reasons of such behavior?

I’d really appreciate any suggestions.

Seems like I have a problem like here. I’ve tried to create a new model and got the same error (Warning: include(PDO.php): failed to open stream: No such file or directory). I checked my php cli modules and it doesn’t have pdo_mysql installed. Is there any way to work without pdo_mysql in php cli, because I actually have all neccessary modules installed in regular php (not php cli though)?

Check if the database server on your hosting is case sensitive. If this is the case, the tableName method of your model should return exactly the name of the table in your database.

Cool, I changed the table names in the database and it worked with some errors. Found the rest of the errors in controller names (case sensitivity stuff). Now everything is up and running.

davi_alexandre, thank you very much!