Logout doesn't work when js is disabled


I’m using the advanced template. I’m doing progressive-enhancement to develop my website, so I’m testing without js. I’m a bit surprised that by default logout doesn’t work when js is disabled. I get a 405 method not allowed. I’m aware that js converts the logout link to an ajax form post. There is no fallback when js is disabled. Is it a bug?



… a bug on your end / in your code?

Just diabled Javascript in FF, Chrome and IE 11 and tried with my local project.

(Also advanced template)

Login / Logout worked just fine.

Do you have customized access control or verb filter in your controller?

Maybe you have setup something wrong there?

Please read this posts for reference:



Thanks for your help.

Yes I have the default verb filter of the advanced template which is set to POST for the logout action. So this can’t work with js disabled.

I supposed you either remove the verb filter or set it to GET or either there was a version of the advanced template in the past that didn’t have the verb filter by default.