Linux host server platform- windows development


This works locally but gives a 404 CHttpexception on Linux platform server.

<?php echo CHtml::submitButton(‘Create a New Team’,array(‘submit’ => array(“home/index”),‘class’ => ‘g-button blue’)); ?><p></p>

ERROR on 000webhost live website

[b]Error 404

Unable to resolve the request "home/index".[/b]

My development environment is windows based.

I recall, somebody told me on this forum that I have to change the file names to make them Linux friendly.

Can anybody please tell me how windows file names should be changed to suit Linux?



By any chance: Have you configured path-style URLs and forgot to upload a .htaccess file? I do not think this is related to filename conventions.

The main windows - linux problem is in the case sensitivity… but if that would be the problem you would get an error of the kind "file X not found"…

Your error is of different kind… so as Da:sourcer pointed maybe you forgot to upload the .htaccess file or if you did that… then mod_rewrite is not enabled on that server… in that case you need to check that with the hosting support.

Not related to this error… but it would be good to check the yii requirements too -

thanks mdomba and Da:Sourcerer

I have my htaccess file at root with this text only RewriteBase /

I also set 755 for assets and runtime folder. Still no success. I will keep on trying.

One small question. How would I check this. For example mywebsite name is


http://hostname/path/to/yii/requirements/index.php ?????????[/b]


Update[/u][/b] my htacess file at /public_html/yii/framework has deny for all . Do I need at add RewriteBase / to it???

For the requirements… could be you did not upload it… when you download yii and unpack it that is located in the "requirements" folder.

Could be that it’s a filename case problem…

Do you use url strict parsing ? or better What is your url settings in the config/main.php ?

thanks!! I checked requirements…everything is green

yes here is my url path format code









Just to give you a context

I am trying to go from site/index to home/index after a button click.


Please make sure you’ve set up .htaccess file correctly to hide index.php. Description in docs

And I don’t see relevant redirect rule in your config, to redirect home/index to site/index, please re-read Url Management topic.

Also, if you just need HomeController.php instead of SiteController.php in your application, wouldn’t it be easier just to rename a class? Additional redirects will give you a bit of additional processing. - Just a small notice, don’t pay an attention to it if it’s not a case.

All seems OK here… the rule home/index should go to the HomeController.php - check the case of that file in your protected/controllers folder.

@yugene please read the first post… he does not need to change SiteController with HomeControlle, or redirect anything… as he pointed in the post just before yours…

So it’s after a button click !

@mdomba…thanks a lot…you beauty…it has worked…I am feeling so silly. I had it named homeController. I have changed/learned so many things in the process though…

@yugene thanks…I will try your index.php hide pointer as well


I realize that this is an old thread but I have a similar problem to the one experienced by OP and I’m running out of time.

The following URL part works as expected on my Windows WAMP machine (running using AMPPS), but fails on the Linux production host:


I get the following error:

Unable to resolve the request "customchocolates/index"

On Windows, I followed the naming convention of CustomChocolates in all the relevant files. However, after searching on-line, I changed the following files to:

controller: customChocolatesController.php

model: customChocolates.php

views dir: customChocolates

I’ve also updated all the class names to the new name, but I’m still getting the error.

I would really appreciate any help.


The controller class and file should be CustomchocolatesController.

ive done that. do I need to change the model file and the views dir, too?

UPDATE: after changes, I still get:

Error 500

CustomchocolatesController cannot find the requested view "index".

Do you have an actionIndex() function?

yes I do.

public function actionIndex()


	&#036;dataProvider=new CActiveDataProvider('CustomChocolates');





You need to change your view path to customchocolates/index.php