JQuery UI - Autocomplete Problem using the mouse


I have a fundamental question about the jQuery-implementation:

Under framework/web/js/source I found the jQuery and jQuery UI files.

As long as there is a problem/bug in jQuery.autocomplete when using the mouse to pick an item (it won’t pick the item from the list…) and this bug was fixed in jQuery-ui 1.8.2 (but still occure in yii when using the CJuiAutocomplete Widget), I took a look at …/source/jquery.autocomplete.js. This version seems to be from august 2009, which isn’t jQuery-ui 1.8.2.

Under ../source/jui/js/ are more jQuery-ui files, which seems to contain something about autocomplete.

Now I am confused.

The yii 1.1.5 changelog claims to use JUI 1.8.6 but the autocomplete-plugin seems so be much older.

Can somebody give me a hint?!

Best regards


There are up-to-date CJuiAutocomplete and deprecated CAutoComplete that uses deprecated non jQuery UI solution. Since we are maintaining backwards compatibility for 1.1.x we can’t just drop CAutoComplete.

Thanks for your reply, Sam.

I took a look around and maybe I started to understand the whole JUI implementation a little better.

So I did the autocomplete-functionality with CJuiAutocomplete. As with Yii 1.1.4 in Yii 1.1.5. there still is a bug in the JUI-autocomplete, where items are not selected when chosen by mouse. As far as I know, that problem was solved in JUI 1.8.2.

Does anybody recognized the same problem and maybe solved it?




I use Yii 1.1.6 (used Yii 1.1.5) and I have no problem. Try to clear the asset directory after Yii update.

i’m using 1.1.7 and have the same problem when selecting items using the mouse click

noticed that the problem only occurs when i put the code to send the form in the selected callback:




with this code, the autocomplete input field is filled with the text I typed instead of the selected text

any idea?