Issue while installing yii 2

Hello Everyone

I need an urgent help in installing Yii 2, While installation , I reached to the step where I am prompted to enter my GitHub username and password to generate token but I got this everytime I enter my username and password:

[b]Could not fetch (Github authorization URL : ), enter your GitHub credentials to go over the API rate limit

The credentials will be swapped for an OAuth token stored in /home/www/.composer/auth.json, your password will not be stored

To revoke access to this token you can visit github applications. [/b]

Please help,


I have the same problem.

Any help


I solved the problem:

  1. Go to and delete your previous token generated during the installation of yii2

  2. Create a new token.

  3. Run this: composer config -g <oauthtoken>

  4. Retry again with the yii2 installation

Now it will not ask for a credentials



I had the same problem. I just followed your first step. Logging in on github was sufficient. Don’t know why…

Please see the line above the cmd, here you will find the url and visit this url and you will git the token and paste the token.

Thanks. It works for me.


I know this is an old thread however,

Installation of a basic web site is NOT POSSIBLE!!!!!!!!!!!!!!!!!!!!!!

OK, Now that I have ranted, I tried to install a yii2-basic app, and can’t. Initially get the “Thou shalt not install without giving GIT all of your Personal information,” line (i.e. Sign up or you can’t use Yii2.) So I signed up.

Went over to the https: web site to get a token. entered it. continued "download" got the following:

Your requirements could not be resolved to an installable set of packages.

  Problem 1

    - yiisoft/yii2 2.0.7 requires bower-asset/jquery.inputmask ~3.2.2 -> no matc

hing package found.

    - yiisoft/yii2 2.0.6 requires bower-asset/punycode 1.3.* -> no matching pack

age found.

    - yiisoft/yii2 2.0.5 requires bower-asset/punycode 1.3.* -> no matching pack

age found.

    - Installation request for yiisoft/yii2 >=2.0.5 -> satisfiable by yiisoft/yi

i2[2.0.5, 2.0.6, 2.0.7].

Potential causes:

 - A typo in the package name

 - The package is not available in a stable-enough version according to your min

imum-stability setting

   see <> for more det


Read <> for further commo

n problems.

So is there a more complicated means that I can use to actually use Yii. I liked Yii1 install, download, unzip, play. But since I have NEVER used GIT, don’t know HOW to use GIT, find it VERY CONFUSING; I’m wondering if it’s time to change frameworks :(

p.s. Oh Yeah, If you have to start over with the download…Sorry that directory is not empty, too bad delete it and start over, and BTW you need a new token…Rinse and repeat B(

See this topic:

You need to get rid of the asset plugin and grab the new one ( 1.1.3 ) - read the topic I linked to for details.

About the Github API key: you only need to enter it once - Composer will remember it.

Don’t blame Yii or Composer - it is Github that has imposed a limit on their API that is unusable unless you use an API key. ;)

Yes, it is a royal pain in the backside, all this funky monkey business with Composer - but, and trust me on that one: you will be so fond of Composer that you can’t believe you ever managed without it! :lol:

Do you have the latest version of Composer Asset Plugin installed globally?

You don’t have to actually use Git. It must be installed on your system but Composer will call Git commands in the background when necessary (typically when downloading via Github web API is not possible), you don’t have to know a thing about it.

You will soon realize that Composer became the standard dependency manager of PHP world and the preferred installation method of practically all frameworks and libraries.


I have the same issue, but it is slightly different. I am facing the issue in, It show me the error while i install any widget in my project.

It requires username and password i have entered here both my git credentials and my packagist credentials. Still it’s throw me same error.