Installing Yii on Mac OS X 10.7

I installed on my new Mac OS X Lion Server, and when I try to access the requirements page, I only see a blank page. So I ran the index.php in the requirements folder at the command line and pasted the result to an HTML file which gives me this:

Yii Requirement Checker


This script checks if your server configuration meets the requirements for running Yii Web applications. It checks if the server is running the right version of PHP, if appropriate PHP extensions have been loaded, and if php.ini file settings are correct.


Unfortunately your server configuration does not satisfy the requirements by Yii.


Name	Result	Required By	Memo

PHP version	 Passed	Yii Framework	 PHP 5.1.0 or higher is required.


Reflection extension	 Passed	Yii Framework	  

PCRE extension	 Passed	Yii Framework	  

SPL extension	 Passed	Yii Framework	  

DOM extension	 Passed	CHtmlPurifier, CWsdlGenerator	  

PDO extension	 Passed	 All DB-related classes	  

PDO SQLite extension	 Passed	 All DB-related classes	 This is required if you are using SQLite database.

PDO MySQL extension	 Passed	 All DB-related classes	 This is required if you are using MySQL database.

PDO PostgreSQL extension	 Passed	 All DB-related classes	 This is required if you are using PostgreSQL database.

Memcache extension	 Warning	CMemCache	  

APC extension	 Warning	CApcCache	  

Mcrypt extension	 Warning	CSecurityManager	 This is required by encrypt and decrypt methods.

SOAP extension	 Passed	CWebService, CWebServiceAction	  

GD extension with

FreeType support	 Passed	CCaptchaAction	  

Ctype extension	 Passed	CDateFormatter, CDateTimeParser, CTextHighlighter, CHtmlPurifier	  

 	passed	 	failed	 	warning

Yii Framework/ 2011-08-30 18:27

can anybody help?


which web server you installed? Apache? Lighttpd? Nginx? Other?

Which PHP version?

I looked and did not see :)

Granted! the PHP cannot report the $_SERVER variables which are not at play from the command line, but since it is the only test that seems to fail, why am I not able to see the Yii test-drive application or the requirements index.php through the web?

Problem solved, it turns out that the problem was with permissions on some folders. I am from a windows environment so this permissions thing is something I tend to forget.


Please explain how you solved this problem. I am using El Capitan and yii 2.0.