Installing problem with lampp

When following the README installing quide, i got an error message from console:

/usr/bin/env: php: No such file or directory


On command line, type in the following commands:

        $ cd YiiPath/framework                (Linux)

        cd YiiPath\framework                  (Windows)

        $ ./yiic webapp ../testdrive          (Linux)

        yiic webapp ..\testdrive              (Windows)


And it happens after typing: ./yiic webapp ../testdrive. I typed it under the framework folder.

I have checked that "env" file and it exists in my computer the right folder.

I didn’t find the same problem in google, could it be accosiated with my old yii-version what I have installed some months ago?


You need:

aptitude -y install php5-cli

Because you don’t have the php command in /usr, assume that you put the lampp in /opt

run these codes in the terminal:

sudo ln -s /opt/lampp/bin/php /usr/bin/php

problem [SOLVED]

Hey thanks! David Huan, it worked.

It could be also the first problem what Mach was talking about but in this case I had PHP already installed.

Hi, my name is Davidhhuan. :stuck_out_tongue_winking_eye:


Thanks mach0, solved my problem on create first yii application and this error come up ^_^

Thanks a lot because i am also stuck at this point.