Installing advanced app via composer freezes at password

I’m trying to install Yii2 Advanced app via composer and it keeps asking for my GIT username and password.

I have successfully installed Yii2 advanced app before and it didn’t ask for this so I don’t know what is different.

It will install Yii2 (puts all the files in place) then starts to installs Yii2 dependencies.

During this process then it asks for my username

i type it in then hit enter

It asks for my password and I can’t type anything at all. I’ve tried numerous times with no avail. I’ve tried restarting the computer too. I can install other packages from git using composer not related to yii2 but not yii2 itself.

Does anyone know how to fix this or if there is a different command to run then the ones in the install guide?

It’s probably asking for your Github username and password. Just type them in and hit enter. When it comes to typing in your password, you won’t actually see the screen update as it’s not shown for security reasons, but it is working. Just type in your password, hit enter and you should be golden.