Installation Commands running composer in Terminal


(Norb Harms) #1

Hello everyone.

Since 5 hours I try to find a solution, but to no avail, so this is my last resource.

On Macbook Pro 10.11.6 I run MAMP and have my sites and composer installed in the htdocs folder. Whenever I try to install YII2 advanced, however, the installation takes place outside the htdocs folder, somewhere in my root folder (which is useless because I can’t open a thing there).

What command line do I need to use to make sure YII2 advanced gets installed into the same web development folder /Applications/MAMP/htdocs?

Thank you

References:

YII own Installation docs first link and second link and third link


(Alexander Makarov) #2

Instead of installing Yii to certain location try adding location sections in your Apache config.


(abei2018) #3

u can select /web as your document directory.


(Alexander Makarov) #4

That won’t help since Advanced template has two webroots.


(Norb Harms) #5

Thanks for the hint, but I use MAMP and that comes with it’s own apache. Directories are set there and are in place. It appears that when downloading YII it ignores those settings and trys to settle at a standard location.
last time I tried using the composer again (away from the manual installation), which seem to start the download, but in the midst, it stopped, again.

Either way, it’s quite frustrating, trying to get YII2 set up. Obviously too many ways and only a few work. So this turns into a “Gamble” strike. It may work with your setup or it may not.

Hm.

Hm.


#6

Any reason you start with the advanced app? Basic app should work quite smoothly without the need to configure a webserver. Just install the app in a directory that the webserver can serve and it should work without any issues.


(Norb Harms) #7

So if I hear you right the advanced version has issues. Doesn’t solve just to install the basic version, does it.


#8

The advanced app does not have issues, but it requires more work on the webserver config to set it up properly. That is based on the nature of the app structure, it is made for quite complex applications. If you just want to start, use the basic app.


(Norb Harms) #9

IC, understood. It’s just that I wanted to do a course and that required to have advanced installed.

Will try to set up basic and see how I go.

Thanks so far.

I may nag you later on again, :wink: