I’m installing YII on my system and have gotten 1.1.3
I get this error after running the command to create the basic project
Your requirements could not be resolved to an installable set of packages.
- yiisoft/yii2 2.0.7 requires bower-asset/jquery.inputmask ~3.2.2 -> no matching package found.
- yiisoft/yii2 2.0.6 requires bower-asset/punycode 1.3.* -> no matching package found.
- yiisoft/yii2 2.0.5 requires bower-asset/punycode 1.3.* -> no matching package found.
- Installation request for yiisoft/yii2 >=2.0.5 -> satisfiable by yiisoft/yii2[2.0.5, 2.0.6, 2.0.7].
All and any help greatly appreciated.
Thank you for your reply Samdark,
Was there a particular section in the link you provided that I overlooked?
That link is exactly what I am following for the installation and I have tried version 1.1.1 all the way to 1.1.3 and still get the same errors.
Delete the asset plugin directory from the global Composer directory and clear the cache.
If you have a project using Composer then I would recommend simply deleting the ‘vendor’ directory instead of trying to fight with Composer.
Because it will most likely just reinstall what you already have installed from the cache.
Maybe this SO post will help you as well: http://stackoverflow.com/questions/17915623/error-updating-symfony-on-composer