include_path on new Server


it is the first time I am setting up a Apache Webserver. Everything is okay, but Yii is not running…

I get the error message ‘Unable to to import “application.models.*”. Please check your server configuration to make sure you are allowed to change the PHP include_path.’

Can someone help me and tell which of the PHP variable I have to give a specific value?

Thank you sooo much!

Check this topic -

okay that was something i expected… very good, but to what do i have to set open_basedir to allow chenging the include_path?

Check the documentation for open_basedir -

I am going crazy… This can’t be so hard… I found out how to change open_basedir and added ‘/usr/share/php/’ to it, as this was the only thing which was missing from my original configuration. In the documentation I can’t find something that lets me see any restriction, sorry… :(

Can you give me a hint or help? Thanks so much!!

I installed a new version of Yii and the same problem here, so it must be the server… But I can’t find the problem… Can Anybody help me?

as the documentation say:

So if you can edit your php.ini… best way to solve this is to not set any directory here… or simply comment that option out with ";"… like:

;open_basedir =