I'm not able to install yiisoft/yii2-apidoc

Hi all,

I’m fighting since a while with composer error. I’m trying to install yiisoft/yii2-apidoc extension but I’m still without any success.

I tried first to follow the step from yii website Install via Composer

Everything is working fine. The next step I added "yiisoft/yii2-apidoc" to composer.json and it looks now:


"require": {

    "php": ">=5.4.0",

    "yiisoft/yii2": "*",

    "yiisoft/yii2-bootstrap": "*",

    "yiisoft/yii2-swiftmailer": "*",

    "yiisoft/yii2-elasticsearch": "*",

    "yiisoft/yii2-authclient": "*",

    "yiisoft/yii2-jui": "*",

    "yiisoft/yii2-apidoc": "*"



After that I tried to execute:

composer update

It stops executing and came up with this message:

$ composer update

Loading composer repositories with package information

Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

  Problem 1

    - Installation request for yiisoft/yii2-apidoc * -> satisfiable by yiisoft/yii2-apidoc[2.0.0].

    - yiisoft/yii2-apidoc 2.0.0 requires cebe/markdown-latex * -> no matching package found.

Potential causes:

 - A typo in the package name

 - The package is not available in a stable-enough version according to your minimum-stability setting

   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.

Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

The core developer said… Everything is working fine… see here: https://github.com/yiisoft/yii2/issues/5082

Did have anyone of you faced a similar or same problem?

Thank you in advance


Does anyone have an idea?

Nope. It’s not that we don’t want to help. We just can’t reproduce the problem.

Himmmm strange…

Thx samdark

This is happening to me on the advanced template with no extra plugins installed. Seems to have installed 1.0.0 instead of 1.1.0

I had to downgrade cebe/markdown to 1.0.2 from 1.1.0 due to requirement on latex being ~1.0.0

I also had to downgrade cebe/markdown in order to get yii2-apidoc installed.

Before trying to install yii2-apidoc, I added the following to the "require" section in composer.json:

"cebe/markdown-latex": "~1.0.0"

Then I executed:

composer update

This downgraded the "cebe/markdown" package automatically while installing markdown-latex.

Finally, I could successfully install yii2-apidoc with:

composer require --prefer-dist yiisoft/yii2-apidoc