I'm getting 429 error constantly


I’m unable to browse this forum - after few clicks I’m getting:


It looks like some anti DoS limits are configured way too low.

1 Like

Seems discourse has rate limiting configured by default, which in our setup was applied to the outer proxy server. That means all requests together were counted to the rate limit.

I have removed that configuration from the discourse setup and applied it on the outer proxy. The problem should be solved now.

Thanks for reporting!

1 Like

Not really. Although I’m not getting this error any more on opening new view, the problem still exists. For example, try open emoji window in post editor - it contains gazillion images (each image = separate request). I’m able to see ~dozen of it, rest of requests gets 429. I’m pretty sure that you may get the same problem with avatars or images in posts.

Good point. That totally kills every reasonable rate-limit…

I have disabled the limit for now…

1 Like

I found the problem:

fixed by adjusting the outer proxy nginx config.

Rate limit is now enabled inside discourse docker again and should be working properly.