How To Have Yii Not Recognize Uri's.


I would like to know if it is possible to make Yii not recognize uri’s (because the values in the column identified as my PK are uri’s). I am trying to use CDetailView to view the view page for a single entry, but get the following error;

"exception 'CHttpException' with message 'The system is unable to find the

requested action "http:".' in


Stack trace:

#0 /var/www/yii/framework/web/CController.php(270):


#1 /var/www/yii/framework/web/CWebApplication.php(282):


#2 /var/www/yii/framework/web/CWebApplication.php(141):


#3 /var/www/yii/framework/base/CApplication.php(169):


#4 /var/www/yii/site/index.php(13): CApplication->run()

#5 {main}



I believe that this is happening because Yii see’s the http: part of the uri (which is the value for my “id” column (column with PK)) - although I might be wrong. The reason why I saw this is because I didn’t have this problem when the values were words. The list view page works fine, but when I click on the link to see a single entry - it does not work.

I have already tried setting the type to raw, but this did not help.

Thank you,