How to browse a special CRUD folder

Hi guys, i just have created several CRUD’s with gii. Everything works fine, except one table called l_textbaustein_art.

Controller has been created by name


Folder,where all CRUD’s have been put in has been named


However I try to call CRUD’s I’ll get error like this:

Not Found (#404)

Seite nicht gefunden.

The above error occurred while the Web server was processing your request.

Please contact us if you think this is a server error. Thank you.

I tried following URL’s:





Everything failed. Any ideas,how to fix this?

Not sure if this helps, but I recently had problems with calling a camelCase action.

actionChangePassword() had to be called r=site%2Fchange-password

Maybe something like that is needed for the camelCase Controller, ie: ?r=l-textbaustein-art%2Findex

Location of the CRUD files (views) can be in directory you want: User views can be in views\employee, or \xyz\123 directory. You would need to tell the controller where they are (possible in beforeAction()).

Also: Why are you calling yiic.php? It should be index.php.

Why are you want to reach yiic.php file?

Is this file really exist?

Yes, I renamed this file, 'cause it’s necessary for Netbeans-Plugin. I solved this problem for my own! Thx a lot for helping me

What plugin? I use Netbeans with web\index.php with no problem. On one development machine with the PHP internal server, and one using XAMPP and vhosts. On the PHP machine, I do have an index.php page with a link to the frontend and one to the backend.

Not sure what yiic does, and in the standard install it doesn’t exist. The yii file is used to run a console app, but the web\index page is the one that actually loads the configs and starts the web app. If you just copied/renamed the index.php file from web\ to root then the

require(__DIR__ . '/../../vendor/autoload.php');

require(__DIR__ . '/../../vendor/yiisoft/yii2/Yii.php');

require(__DIR__ . '/../../common/config/bootstrap.php');

require(__DIR__ . '/../config/bootstrap.php');

are ALL pointing to the wrong location. As well as the config files.