Help - yii configuration on mac

Hi All,

I am coming from a codeigniter background and was looking at kohana, when I stumbled onto yii.

I recently switched to Mac and am having configuration problems running yii

I want to learn yii by using the blog tutorial.

while in the shell, I ran the model * with no problems.

however when I run the crud Post

the shell terminates.

What is the best way to run yii on Mac?

Do I develop apps inside the yii folder?

I would like to make this easier.




Still not working.

>>crud Post

Shell exits.

Check server log and/or php log for errors?


here is the php error log:

[27-Feb-2010 19:54:22] PHP Warning: include(): Failed opening ‘/Users/farocco/Sites/blog/protected/models/Post.php’ for inclusion (include_path=’.:/Users/farocco/Sites/blog/protected/components:/Users/farocco/Sites/blog/protected/models:/Applications/MAMP/bin/php5/lib/php’) in /Users/farocco/Sites/yii/framework/YiiBase.php on line 335

[27-Feb-2010 19:54:22] PHP Fatal error: Class ‘Post’ not found in /Users/farocco/Sites/yii/framework/db/ar/CActiveRecord.php on line 326

This generated after I did the crud Post

Do I have a bad install?


I just realized that the table Post is TblPost and I was following the tutorial for the blog.

So crud TblPost works

Sorry for the wasted time.


If you are following the blog tutorial, you should set ‘tablePrefix’ in main.php so that the generated model classes do not include the Tbl prefix.

Ok, thanks qiang.

Hope all is well, I remember you back in my Prado days. :slight_smile:

I want to get up to speed as quickly as possible for an upcoming project.

I am comparing how I did things in codeigniter and what I need to do in yii.

Great framework, your one smart guy.



I just checked main.php and do not see a tablePrefix

do I just enter tablePrefix=‘tbl’


I figured it out.