Giix Crud Issues File Not Found

Having an issue due to missing some field I probably needed to update.

Had a table named ‘tbl_project’ and wanted to create a clone of it called ‘tbl_projectG’

Since I had already use Giix to generate Model and CRUD of tbl_Project, I just cloned all the

controller, model, and view folders and files for Project, and named them ProjectG. I also

did some edits to the files to change references to Project to ProjectG.

Anyway, everything was fine, all functions worked as expected when testing the cloned ProjectG.

But then I added a new table to the application: tbl_test

When I ran giix Model gen on it, it worked fine. But when I tried to do giix CRUD gen, I got this error:

[i]PHP warning

include(BaseProjectG.php) [<a href=‘function.include’>function.include</a>]: failed to open stream: No such file or directory[/i]

But that file DOES exist, so I’m wondering ig giix keeps a list somewhere that I need to update?

Never mind. Fixed it.

It happens to me sometimes, but in my case it isn’t related to giix or Yii.

My VM takes some time to update its filesystem cache. So, if you’re using a VM, restarting it should fix the issue.