Gii Non Parte, Come Se Non Esistesse


(Box Carlo) #1

Vorrei sperimentare il modulo Gii per creare models. Ho configurato il main.php come spiegato nella guida, ma quando accedo alla homepage e faccio il login (user: admin passw: admin), poi digito http://www.nomesito.com/index.php?r=gii

Non succede niente, resta sulla home page come se non avessi fatto nulla …

Ho configurato anche MySql dentro main.php ma niente, ho attivato la parte Url manager, tutto il necessario, insomma (o così credo).

Qualcuno può aiutarmi ?

Grazie

Carlo

Chi volesse verificare può accedere http://www.risparambio.org, poi login user admin passw admin, poi http://www.risparambio.org/index.php?r=gii


(Sensorario) #2

Leggi bene i commenti che trovi nel file di configurazione. Gii non è accessibile se non da localhost, per questo non ci puoi accedere quando il sito è pubblicato. Devi utilizzarlo in locale.


(Rg) #3

Ciao, se hai attivato URL Manager l’indirizzo per accedere a Gii nel tuo caso è

http://www.risparambio.org/index.php/gii

Visitando il tuo sito quindi ricevo un avviso

[b]Error 403

You are not allowed to access this page.[/b]

probabilmente perchè il mio IP address non è nella lista di quelli permessi.

Una volta inserito l’IP address corretto nel file ./config/main.php tutto dovrebbe funzionare.




		'gii'=>array(

			'class'=>'system.gii.GiiModule',

			'password'=>'la tua password',

			// If removed, Gii defaults to localhost only. Edit carefully to taste.

			'ipFilters'=>array('127.0.0.1','::1','il tuo IP'),

		),



Ciao

R.