Gii Generator Redirects To Another Page?

I am trying access the GII generator, and I’ve add the following code to my file like the help files said I should:










Problem is, The moment I add my ip address, when I go to the gii URL, it then redirects me to my site’s default login page (the member login page of the script my site is running on), which is

If I remove the ipfilters line, I get a 403 error saying I’m not allowed to access that page.

I did double check that my ip address is correct (just removed it in the above code)

Any help?

Does the note at the bottom of this page apply to you?

Thanks for the reply, but I just did that, and it doesn’t work… it just redirects me back to the homepage. :(

Any help anyone? I would really love to get into the generator :(

Do you want to use gii in your remote production machine?

Or, in your local development machine?

And what do you mean by "my ip address"?

It’s not on localhost… it’s on my hosting account. And the help files said to add the “ipFilters” line if you want to connect that way… that’s what I meant.

And you’re definitely using your external IP address?

Yes, I’ve double checked it like a zillion times…

Can you post your URL manager rules here?

Thanks for the help! But I finally figured it out! It was a setting inside the script I was using. It’s working now! Thanks!