Gii and the browser

After some time of searching the web for a solution to why Gii wouldn’t let me preview a Model Generator code, but instead always returned a new page with the message “Unable to find the code you requested”, I at last realized that I had :rolleyes: disabled javascript in the browser. So if you are experiencing something like me, the solution could simply be to enable javascript in your browser.

thanks Frikki for sharing this … if it was me, i am sure that i won’t solve it at all if i didn’t read such a post

Ha, nice “bug”. Gii could need some ‘unobtrusive javascript’ I think :)

Good, and I think it should be a JS test in the first page to check if it is disabled then warns it.

I had almost same problem with Gii code preview(Unable to find the code you requested). For this, my solution was:

Add in config.php, ‘urlManager’