Getting Blank Screen on login to show errors

Hello all. I have a Yii installation that I’m trying to get working. It was originally on one server and I’ve moved it to a new server. The base site comes up correctly but there’s a login part that just gives a blank screen when I give the login credentials. I’ve looked up a number of threads on this issue and the ways to resolve it differ, but the consensus seems to be that an error display is off.

So in the root index.php I added the following:
ini_set(‘display_errors’, true);
define(‘YII_ENABLE_ERROR_HANDLER’, false);

defined('YII_DEBUG') or define('YII_DEBUG', true);
//defined('YII_ENV') or define('YII_ENV', 'prod');
defined('YII_ENV_TEST') or define('YII_ENV_TEST', true);

I later saw that the index.php in the web/ dir was the proper place to put those lines for them to be effective, so I put them in that index as well.

Since I’m still getting the blank page, I checked the site logs, or so I thought. The site is running on CentOS and the access_log and error_log are located in /var/log/apache2/. I figured when I try to log in and get a blank screen I’d have an entry in the error_log but that doesn’t seem to be the case. In fact, it doesn’t seem like the access_log is getting entries either. They do get some entries though and I can’t be more specifc than that. I access the site and check the log and it doesn’t seem to log my access. The site is set up under my username, and there’s a log there but the same thing seems to be happening: it doesn’t seem to log all of the accesses. This log is at /etc/apache2/logs/domlogs/ and is called “”.

All I’m really looking for is some log of what’s happening. If anyone has any ideas of other log locations or how to actually get errors to show up I’d be grateful. Thanks.


Why have you disabled Yii’s error handler? Switch it on unless there is a specific reason to not do that. Also set YII_DEBUG to true and YII_ENV to dev to see the errors in the dev environment. You don’t need YII_ENV_TEST. You should see logs in the runtime/logs folder. As for the server logs - check if the server log directory exists and is writable.

Ok, so I set YII_DEBUG to “true” and “YII_ENV” to “dev” and enabled the error handler and I finally got logs. I found the log under “runtime/logs/” and have worked through all of the errors. As I solved them they no longer showed up in subsequent writing of the log. Now it seems that I’ve solved all of the errors that were being logged but I’m still getting a white screen when I try to log in. No more data is being written to that log.

I confirmed by changing the “allowedIPs” to only localhost and the log contained the error “Access to debugger is denied due to IP address restriction”. I changed the allowedIPs to “*” and that error was no longer written to the log. I also removed the “site/images” folder and received errors about not being able to find images. I put the folder back and now nothing it writing to the log.

So is there somewhere else I can look to see why I’m getting a white screen upon logging in?