Forum search doesn't show results on first try

I keep getting zero results from searching this forum.

And I noticed (just now) that the search is case sensitive??

Wtf? :)

Could you please consider making it case insensitive, thanks.

I searched for runconsolecommand and zero results.

Then I searched for ‘runConsoleCommand’, and bingo.

You want to search for ‘group by date’ ?

Forget it. ;)

If you can manage to improve this, I’d be very happy.

Maybe you need to let Google crawl this forum?

There’s not much help in using Google either.

Is it because you have blocked it?

Thanks. :)

Not the best search engine I’ve seen, but I don’t think Yii developers would like to change IPBoard source code :D Try this:

Thumbs up. :P

But in most forum software, there are options to turn on/off full text search, etc.

And there’s also an option of allowing spiders to crawl certain areas of the site.

I am just interested in Yii having the best facilities it can possibly have. :)


Advanced search does indeed work.

1 result for runconsolecommand.

Very exact. Just perfect. :)

Could a forum operator please check what the default search options are for the basic search?

When I go to advanced search, I have to explicitly choose ‘forum’ as the place to search.

And the search itself it by default case insensitive.

I don’t mind the extra work required to actually find thing around here, but it would be awesome if it could be default?


Each succesful search means a question or two less, and thus bonus for everyone. ;)

Yeah i certainly agree, its gonna be a big help for forum searchers if you could modify the default settings a bit though I wouldn’t mind searching topics that i really need. Its gonna be more convenient and faster for us plus I think more people will be encouraged as well since having to return zero results just is not exactly encouraging at first.Just some suggestions.:)

I noticed a bug with the forum search highlighting:

The searched keywords seem to get highlighted by adding a DOM-element and a class around them.

" <span class="searchlite">View</span> "

But after this first replacement, the entire text is searched again for the next keyword, including the new highlighting!

See an example here (‘view’ and ‘cla’) highlighted.

Yep… definitely true! I solved the problem with one… actually two google custom search engines:

I know what you mean, up to now there are several points missing in the Forum like a video and a mod corner and so on.

To be honest: I think a place like youtube is enough to see crashes just for sensation, dont you think so?

I noticed this some days ago and thought it is a temporary problem but if I use the site’s search functionality I usually have to search 2-3 times until some results show up. Sometimes only class reference results are shown on the first try. I guess it is a Sphinx search problem (if I remember correctly)

Sorry, typo: It’s not the forum search but the site search of course


Has anyone else noticed the errors in displaying search items on this website??

80% of the time using the search feature for looking up classes or forum posts it hangs then displays zero results. I have to hit reload a few times just to get it to display something. This has been happening over the last few months.

This is very frustrating as I use this ALL THE TIME, as I’m no expert yii developer yet![/size]

Always had this issue :( Its getting better but still has tons of issues

I love Yii, don’t get me wrong. But, it might not be the smartest idea to have a buggy website for a web framework. It might give the wrong impression to folks thinking of trying it. Just thinking…

I noticed that this week, when I was searching for some extensions, so I had to use google search on yiiframework website. I am sure they will fix it :)

Interesting how Yii search implemented…

Maybe it is Zend Lucine

I tried both forum search and site search a minute ago and both needed a second try before finding anything at all.

I recommend the use of google as an alternative: " … …"


Just tried to search for a few things this morning… and it’s not working at all now! Can we get this fixed?


I have no implementation knowledge regarding the site and forum search. Personally I use to use Google " <my search phrase>" as an alternative.


First of all, try to give a better topics, when starting a new thread, to be noticed! "Problems searching" seems to be better in this situation! :]

Yes, searching does seems to be working badly lastly. It this keep repeting, try to open a ticked on yii bug tracker.

I can personally only advice you, that using C before class name, when searching for a particular class can sometimes give results, when using class name without C in the beginning can bring no search results at all.

I’m using dummy search engines idea. That is - I’ve created a bookmark in my browser (Firefox particullary, but I heard that it works in most of them) in a folder outside menu and bookmarks toolbar (as I’m not using this bookmark directly), named it “Yii Search” and gave it such URL:

notice, q=%s.

I have also gave this bookmark a keyword y. And now I can simply type "y CController" in my browser address bar to have this bookmark executed and get to results of searching within seconds.

Tri - Thanks, I’ve been using Google in the same manner as you suggested. It works. I’m worried it won’t pickup new forum topics though.

Trejder - Suffice it to say - I’m not interested in your duct taped, paper clipped, rubber-banded Firefox solution. Also, if I’m reading your post right, if I want to search for CActiveRecord, I should put CCActiveRecord? Thanks anyway.

Bottom line, it’d be nice if the search feature was fixed!