Extension installation - Installation of asset plugin

I am using the basic template and installed yii2 manual(using compressed file); Whenever I wanna install an Extension of specific version I am getting this error message:

Your requirements could not be resolved to an installable set of packages. Problem 1 - yiisoft/yii2-jui 2.0.4 requires bower-asset/jquery-ui 1.11.@stable -> no matching package found. - yiisoft/yii2-jui 2.0.3 requires bower-asset/jquery-ui 1.11.@stable -> no matching package found. - yiisoft/yii2-jui 2.0.2 requires bower-asset/jquery-ui 1.11.@stable -> no matching package found. - yiisoft/yii2-jui 2.0.1 requires bower-asset/jquery-ui 1.11.@stable -> no matching package found. - yiisoft/yii2-jui 2.0.0 requires bower-asset/jquery-ui 1.11.*@stable -> no matching package found. - dektrium/yii2-user v0.9.5 requires yiisoft/yii2-jui ~2.0 -> satisfiable by yiisoft/yii2-jui[2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4]. - Installation request for dektrium/yii2-user v0.9.5 -> satisfiable by dektrium/yii2-user[v0.9.5]. Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details. Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems. Installation failed, reverting ./composer.json to its original content.

What can I do? Is that because I am missing asset plugin? and how can I install it

Yes, this is the reason.

You should install Composer - without it every update is problematic.

Follow the guide here: http://www.yiiframework.com/doc-2.0/guide-start-installation.html

I installed yii2 manually Do I just have to type: composer global require "fxp/composer-asset-plugin:~1.1.0" to install it? I did it and think it is working because the error message is not poping up anymore

Yup, this is it.