[Extension] Bootstrap

Hi all members,

Being a yii’s newbie, I’d like to use Chris’ yii bootstrap, but I couldn’t find any place where to look at same php exemples and specially, to know all it’s classes and methods.

Could you please shed some light on this topic, please?


Susan Tità


did you check out the demo page ? http://www.cniska.net/yii-bootstrap/

I couldn’t find anything else like a lass reference page, but the demo pages contains plenty of helpful examples. When I need to know more … I check the source code ! Most of the time, Bootstrap widgets are based on standard Yii classes, so the Yii doc api is also helpful.



Thanks a lot for your help. You’re right, I can go through the exemples. It’s just too much stuff same time (yii & bootstrap) but I’m doing my best :slight_smile:

So far, I’ve been able to implement some of the navigation classes.

I’m now stacked at the CRUD model I generated using GII & Bootstrap CRUD generator.

I can create new items, update them, etc… but when I click on the ‘manage’ option menu I onl get:

"Manage Users

You may optionally enter a comparison operator (<, <=, >, >=, <> or =) at the beginning of each of your search values to specify how the comparison should be done.

Advanced Search"

and none of the created records are displayed.

I’ve been looking at the admin.php (underneath ../views/user) but since everything is to automatic, I have problems in understanting some of the code.

ANy light on this would be greatley appreciated.



I answer to myself.

I generated a CRUD usign YII’s GII-Bootstrap and when selecting “Admin” button, the rows did not get displayed correctly because of an expecting ‘)’ missing, which was in ../protected/views/user/_search.php.

IT was in the following block:

<?php $this->widget(‘bootstrap.widgets.TbButton’, array(




  )); ?&gt;

Once I added the comma in the second line, it worked flawlessly.

Thanks and regards,


hi guys

i’m newbie to yii & i’m trying to install booster as well described in the home page but without sucess.

the extension works, i generated CRUDs using ‘bootstrap.gii’ but i steel having the classic blueprint theme. there is my view output :


	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

	<meta name="language" content="en" />

	<!-- blueprint CSS framework -->

	<link rel="stylesheet" type="text/css" href="/thouraya_booster/css/screen.css" media="screen, projection" />

	<link rel="stylesheet" type="text/css" href="/thouraya_booster/css/print.css" media="print" />

	<!--[if lt IE 8]>

	<link rel="stylesheet" type="text/css" href="/thouraya_booster/css/ie.css" media="screen, projection" />


	<link rel="stylesheet" type="text/css" href="/thouraya_booster/css/main.css" />

	<link rel="stylesheet" type="text/css" href="/thouraya_booster/css/form.css" />

	<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<link rel="stylesheet" type="text/css" href="/thouraya_booster/assets/b50f179f/css/bootstrap.css" />

<link rel="stylesheet" type="text/css" href="/thouraya_booster/assets/b50f179f/css/bootstrap-responsive.css" />

<link rel="stylesheet" type="text/css" href="/thouraya_booster/assets/b50f179f/css/bootstrap-yii.css" />

<link rel="stylesheet" type="text/css" href="/thouraya_booster/assets/b50f179f/css/jquery-ui-bootstrap.css" />

<script type="text/javascript" src="/thouraya_booster/assets/f74bdb93/jquery.js"></script>

<script type="text/javascript" src="/thouraya_booster/assets/b50f179f/js/bootstrap.bootbox.min.js"></script>

<script type="text/javascript" src="/thouraya_booster/assets/b50f179f/js/bootstrap.js"></script>

<title>My Web Application</title>


i tried to add manually the bootsrtap theme as it use to be with chris’s bootstrap extention but i’m getting this error message ‘Bootstrap and its behaviors do not have a method or closure named “register”.’

i tried to manually modify the layouts/main.php exchanging the blueprint loading css by

<?php echo Yii::app()->bootstrap->registerCoreCss(); ?>

but it dosn’t work

i even tried a chmod777 for if access is denied to some css file and the extension is then replacing it by the yii’s default one.

here is how my config file looks like:


// preloading 'log' component





	// autoloading model and component classes










			// If removed, Gii defaults to localhost only. Edit carefully to taste.


                        'generatorPaths' => array(





	// application components



                'bootstrap' => array(

                        'class' => 'ext.bootstrap.components.Bootstrap',

                        'responsiveCss' => true,



i don’t know if i’m missing something somewhere.