Euploadify No Buttons


I’ve been trying like crazy tonight to get the EUploadify extension to work in my app. As in the documentation, I extracted the .zip file into my extensions directory. I at first thought it might be because I’m not explicitly setting the path to the uploader etc, but even setting those didn’t work.

Should this have worked (albeit in a basic sense) right out of the box like it seems to imply?

In the view: ($model is a FormModel)





        'options'=> array(

            //'uploader' => '/js/uploadify.swf',

            'script' => $this->createUrl('profile/ajaxUpload'), 

            //'cancelImg' => '/js/cancel.png',

            //'auto' => true,

            //'multi' => false,

            //'folder' => '/tmp',

            'scriptData' => array('extraVar' => 1234, 'PHPSESSID' => session_id()),

            //'fileDesc' => 'Declaratiebestanden',

            //'fileExt' => '*.*',

            'buttonText' => 'Upload',

            'buttonImg' => '/images/btn.gif',

            'width' => 100,


        'callbacks' => array()


What happens is that it displays the input field but no buttons, and hence, no way to kick of the upload.

Any suggestions? There doesn’t seem to be any indication anywhere else that this is anything less than easy so I can’t seem to understand why this is so frustrating.



Does it insert any JS inside the document?

Yes, it inserts the jquery script and the uploadify script in the head.


Turns out some of my assets were out of date. Clearing out my asset folder fixed it.

lostmahbles did you implement this? how you did it… i cant do it and also noob on Yii… thanks