Error With Slash


I have changed urlManager rules



	'<community:(ukuya|mspc)>' => '/social',

	'<community:(ukuya|mspc)>/<module:\w+>/' => '<module>',

	'<community:(ukuya|mspc)>/<module:\w+>/<controller:\w+>/' => '<module>/<controller>',


	'<community:(ukuya|mspc)>/<module:\w+>/<controller:\w+>/<action:\w+>' => '<module>/<controller>/<action>',								



when I type

"" it is working” it gives me error (You don’t have permission to access /social/ on this server.)

"social" is a module.

but in my localhost everything is fine?

can anyone help me?


Maybe it has something to do with your htaccess?

I had such issues with Nginx so I would point you to your http server config.

my .httaccess [server side: Apache/2.2.21 (Amazon) Server]

RewriteEngine On

RewriteCond %{REQUEST_FILENAME} -s [OR]

RewriteCond %{REQUEST_FILENAME} -l [OR]

RewriteCond %{REQUEST_FILENAME} -d

RewriteRule ^.*$ - [NC,L]

RewriteRule ^.*$ index.php [NC,L]

in my local same settings

Apache Version: Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1

Seems like you have actual /social/ folder inside webroot, and directoryIndex is off.

I have social module. (protected/modules/social)

weird thing is, that in my local it is working.

I have checked server’s modules/social folder, found .htaccess file in it,

and deleted it. still not working

And did you check if there’s a social directory directly in your webroot? Not in the protected dir but one up.

yeap there’s social directory in webroot.

thank you.