Error Failed opening required '/app/common/config/bootstrap.php'

Good day. I run it inside Docker and I don’t quite understand this error. The search has not given any results. How to solve this? All dependencies are installed, PHP 7.3, I look in the / app / common / config folder and there really isn’t it, and where should it come from or after what actions? Environment tried both dev and prod

Failed opening required '/app/common/config/bootstrap.php' (include_path='.:/usr/local/lib/php') in /app/yii on line 12

I don’t know why it is missing, but you can find it here

(I assume you are using the advanced template)

Hi, thanks. But that didn’t solve my problem because there are many files missing besides it. Apparently they are automatically somehow formed and I don’t understand how exactly, For example, after I add bootstrap.php, it already requires main.php

I’m not (yet) familiar at all with the Docker concept so I don’t know what it should look like or what steps you have taken to get what you have there. (Did you install advanced template or something else or is it an existing Docker container).

Perhaps somebody else can help.

Running it inside of docker or not is not the problem here, some base files are missing. The bootstrap.php file is part of the yii2-app-advanced project (take a look here).

Try a git pull on the root folder, or check your git status, this files should be missing.

The *-local.php files are inserted automatically after you run the php init command. This will setup configurations files specific for your environment (very useful for things like db password).