Error: Attempt to write to a read-only database (even after chmod 777)

I built an app that I have run on Windows for a few years now (currently running Yii 2.0.31 and PHP 7.4). Now, I am trying to run it on a Mac via Xampp but am running into the error “attempt to write to a readonly database” whenever I try to update, insert or delete from the SQLite data file. Reading data works just fine. I’ve gone as far as chmod 777 the data folder and the database, but still get the error. I’m rather stumped.

Yii Framework: 2.0.31
PHP: 8.2
MacOS: Mojave and Monterey
Data Location: /Applications/XAMPP/xamppfiles/htdocs/myapp/common/data

I did try upgrading the Yii framework to 2.0.47, but still ran into the same error.

That’s definitely a file permission issue. It is weird, though, that 777 did not help.

Yes, that’s why I am stumped. I would think that chmod 777 would take care of it.

Only other thing that I can think of is an ownership issue, but again a chmod 777 would seem to make it read/write for everyone. I know just enough about Macs to be dangerous, so I don’t know the quirks of that OS.