Disable Input Errors: Dummy On Ajax Validation

Hello all , thanks for reading , i am wandering how to disable the following message :

Please fix the following input errors: dummy,

I enabled ajax validation and now i keep on getting that message. can someone explain to me what it is reffering to and how to disable it on ajax validation?

Hi gunnit,

What is "dummy"?

I mean, you have to elaborate your code a little more, otherwise we have no means to understand your issue.

This is generated by CHtml::errorSummary, remove it and you are done.

Oh, is it? I didn’t know that. :(

I get "dummy" as a default value when i want to create a new reccord, but this only happens when i enable ajax validation. If i take off error summary i do not see the actual validation error messages . If iam not clear i can elaborate further

I think you have to post the relevant parts of your view and model as well.

It should come from CActiveForm’s errorSummary() code:

  public function errorSummary($models,$header=null,$footer=null,$htmlOptions=array())


    if(!$this->enableAjaxValidation && !$this->enableClientValidation)

      return CHtml::errorSummary($models,$header,$footer,$htmlOptions);







        $header='<p>'.Yii::t('yii','Please fix the following input errors:').'</p>';



      $htmlOptions['style']=isset($htmlOptions['style']) ? rtrim($htmlOptions['style'],';').';display:none' : 'display:none';

      /* line 529 in v1.1.12 */




    return $html;


Thanks, bennouna. I didn’t know that.

But the display of that ‘dummy’ should be kept hidden by ‘display:none’ …