Directory not writable CException

I am new to linux. I’ve setup ubuntu 11.10 in my PC. I’ve also installed the XAMPP 1.7.7 But there seems to be a problem.

I am unable to make my runtime directory writable to the browser process.

I know that a chown command will do the trick and I have tried

sudo chown -R www-data /opt/lampp/htdocs/myProject/protected/runtime/

but it seems to do no good. Please help me out…

Check this out

Change permissions of directories

It worked for me.

Thanks a lot.

I tried the chmod and chown commands mentioned in the post. It did not work out for me.

One thing I noticed there was that the one who wrote the post was working in an environment where his apache is loading the pages from /var/www/ directory I on the other hand is trying to make a directory in /opt/lampp/htdocs/ (xampp 1.7.7) writable by the web server process.

I don’t whether this is a stupid thing to ask but I am really having the doubt that my webserver process has a different name (something other than www-data).

Or is it wrong to install xampp in /opt directory ?

I would recommend you to use Ubuntu’s apache implementation instead of Xampp’s … it works out of the box and there are plenty resources on how to configure it out there.

mauriciorivera thanks for the advice i did switch to the Ubuntu’s apache implementation and it did fix the error

but now I’m left with the issue of undefined variables in may be configuring my php.ini will do the trick :)

I’m trying to implement little default app that comes with yii framework on phpfog. I’ve installed it according to the instructions using GIT. Now, when I try to run it, I get this error (below)

I’ve checked to make sure that the directory is writeable and that the directory called for does exists. Yes on both. I’m sort of stuck. What do I do next? :rolleyes: