Different behavior between localhost and production web app

Hi there,

I am trying to maintain an existing app developed on yii 1.1 by another team

I am having a bad time making it run on my localhost

I dumped the database and restored it on my mySQL localhost app on Mac OS X 10.11

I copied also all the files (or so I think) to my localhost/~user/ and it works for at least some first "static" pages

I am trying to use the search forms and personalise them

whenever I try to search for some records with the search form, while it works perfectly on the production remote server, I have an error message

Error 500: <h1>PHP Error [8]</h1>

<p>Trying to get property of non-object</p>

Then I tried with a MAMP installation to see if it makes a difference, but none, always the same message

Localhost:8888 says

Error 500: <h1>PHP Error [8]</h1>

<p>Trying to get property of non-object</p>

please help

It worked for me once by doing the following steps:

  1. install yii and run through local host.

  2. install the database and configure the protected\config\main.php

  3. when the installation is working fine, replace the folders in protected directory like components, controllers, extensions, views etc with that of the existing app.

Hi and thanks for the answer

but this solution is firing another error

PHP warning

include(GxActiveRecord.php): failed to open stream: No such file or directory

Are you sure this is the best solution, what other difference could be between localhost and a real server?

I am reading some other forums, it seems that some timeout is making php getting an empty object, does it make sense?

could I just change the timeouts??? which ones? would it be mySQL or Apache who is going in timeout?