Is there any way (or are there any plans to add a way in future releases) to make CActiveForm’s name prefix customizable?
Currently, it uses get_class($model) to resolve input names, like MySuperModel[myInputName]. I would like to have an option to give a custom prefix instead of class name. Maybe it’s a good idea to replace get_class($model) with something like $model->getFormPrefix()?
I need this for rendering multiple different models to one form: I want the models to be parts of an array. Inputs of the first model should be named like MySuperModel[myInputName], the inputs of the second one — like MySuperModel[myInputName], and so on.