Creating First Yii Application - missing directories

Dear All,

Completely new to Yii, but experienced prorammer (initially Pascal, C, C++, Assembly - recently [4 years] HTML, CSS, PHP, MySQL, Javascript), I have followed the "Definitive Guide to Yii" tutorial and, at least in my installation on a WAMP system (EasyPHP - Windows XP service pack 3, Apache 2.2.13, PHP 5.2.10, MySQL 5.1.37), the

"[font="Courier New"]% YiiRoot/framework/yiic webapp WebRoot/testdrive[/font]"

command generated an application directory structure with at least 3 missing directories, two of which under the "protected" directory:

  • protected/runtime

  • protected/commands

  • assests

Since the yii created application was complaining, I created these directories manually, and everything went fine from then on. I also tried to track the Yii code to find out where/when the directory tree was created and populated, but gave-up before reaching the bottom of it (taken away on other duties)

I think this point may be worth looking at, may be, …?



You can find this template directory structure under framework/cli/views/webapp.

You are right - and, apologies/my bad - the "missing directories" were actually present under

[font="Courier New"]framework/cli/views/webapp[/font]

in the zip archive, but not in my extracted tree

My "unzip" tool must have not extracted the empty folders…!

Sorry; as stated above: my bad!



First explain about your framework

Wht is ur OS?

Wht is ur Host Server?

Where and how do u install ur framework?

Have u changed any files in the framework directory?


Hi, Ali Borjian,

It’s OK, the issue is resolved (I’ll try to close the topic if it is possible).

OS/Server/PHP version … are in my initial post

What happened was:


[*]The tool I use for uncompacting zip archives did not extract the empty folders from the Yii archive

[*]So the directories

  • assests

  • protected/commands

  • protected/runtime

Were not extracted under [font="Courier New"]framework/cli/views/webapp[/font]

[*]So, when I ran

[font="Courier New"]% YiiRoot/framework/yiic webapp WebRoot/testdrive[/font]

these directories, not being under [font="Courier New"]framework/cli/views/webapp[/font] were thus not copied under my application directory tree and blocked the application from working properly.


I recreated the missing directories thinking that there had been a glitch in the Yii web application creation script, when, in fact, the whole problem was, initially, with my Zip extractor…!

Voilà, story over.

Thanks & cheers,