Composer update requeriments not be resolved


(Toki Aquino) #1

Why composer update fail because php >= 7.1.0 dependency, when the composer.json only specify >=5.4.0




php composer.phar update --no-dev --prefer-lowest --prefer-stable

Loading composer repositories with package information

Updating dependencies

Your requirements could not be resolved to an installable set of packages.


  Problem 1

    - yiisoft/yii2 2.0.x-dev requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.

    - yiisoft/yii2 2.0.15.1 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.

    - yiisoft/yii2 2.0.15 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.

    - yiisoft/yii2 2.0.14.2 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.

    - yiisoft/yii2 2.0.14.1 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.

    - yiisoft/yii2 2.0.14 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.

    - yiisoft/core 3.0.x-dev requires php >=7.1.0 -> your PHP version (7.0.30) does not satisfy that requirement.

    - yiisoft/core dev-master requires php >=7.1.0 -> your PHP version (7.0.30) does not satisfy that requirement.

    - Installation request for yiisoft/yii2 ~2.0.14 -> satisfiable by yiisoft/core[dev-master, 3.0.x-dev], yiisoft/yii2[2.0.14, 2.0.14.1, 2.0.14.2, 2.0.15, 2.0.15.1, 2.0.x-dev].




(Gildoduarte) #2

Good evening!

From what I read from your log, the composer is trying to install the yiisoft/core (version 3.0.x), which requires PHP 7.1.

Which version of the framework are you trying to use?


(Toki Aquino) #3

I use the template yii2mod/base which have like requirement "yiisoft/yii2": "~2.0.14" in composer.json

There Is it possible to lower dependency to php 7.0.30? Because is the php version i have available.