Changed Directory Structure After Git Clone

HI All,

I tried to create a webapp in my linux machine and tried downloading it into the windows environment as a clone using the GIT Clone option.

The problem is the directory structure isn’t the same between the original src (present in linux machine) and the clone.

For ex: Folders like runtime and extensions are not present in the clone itself but are present in the original src code.

I am guessing the problem might be with file permissions in linux but have no clear idea on how to solve it.

ERROR MSG: (while running the application)

Application runtime path "\protected\runtime" is not valid. Please make sure it is a directory writable by the Web server process.

Also tried changing the permission for the yii directory to 777:

chmod -R 777 * … But it still doesn’t seem to work.

Any help would be much appreciated.


I think it is choking on the fact that the directories are empty - try putting a blank .gitkeep file in there so the directory will be tracked.


Also, you can follow the example of yii2, and put a .gitignore in the runtime directory:



Definitely that was the problem. Using the gitIgnore helps to maintian the empty directories in GIT.

Thanks a lot.