captcha rendered partially

Hello everyone.

Did any of you have problem with captcha rendered partially?

When I load the contact page the captcha code is blank or there is just shown one or two letters. The full captcha code is shown only after I click ‘Get a new code’ for several times.

You can see this strange behaviour here - this just standard yii webapp created following instructions from The Definitive Guide to Yii.

However I must note that on my local machine it works ok.

What can be the problem?


I’m testing with MacOsX

Chrome work

Safari dont work

Firefox dont work

=( I cant help you.

Looks like the problem occurs only on the servers that work under Debian Lenny. It’s interesting if someone of our community uses debian lenny servers and has the same problem with captcha like me.

Hm I got it at the first time I entered…

BUt now it looks ok

Hello viter

Did you fixed it?

I was going through renderPartial and come to this same issue, the captcha is not being generated and its rendering the same captcha… i am stuck in this issue is there anyone who came across this issue please help to git out of it

have you tried with the captcha extended extension?

I once my captcha didn’t show at all, and it was because of the components > Controler.php init() method. For example, if you write an “echo” in this method, the captcha doesn’t display.