Cache problem in webservices

Hi All,

I have used YII framework SOAP webserives for my project ,

And using normal PHP code to send the soap Client request to the YII web services(soap server).

In YII (soap server) if i change the signature by adding new fields(object) in the WSDL it will not working immediately by calling php client request.

I have tested in SOAP UI its working Good , But normal PHP it takes some more time to update the signature , i think any cache have set in the framework , so that it takes time to update.

Can any ane faced teh problem , please let me know the solution for the issue.

Thanks & Regards,


You can set a shorter soap.wsdl_cache_ttl in php.ini. Can be done programmatically by calling ini_set()

ini_set(soap.wsdl_cache_ttl, '60'); // default 86400 secs

or (possibly)

ini_set(soap.wsdl_cache_enabled, '0');

ini_set(soap.wsdl_cache_enabled, '1');

(ini_set not tested, I’ve only used php.ini )


Thanks Tommy , its working :)



Thanks, It is working :)

To enable cache :

ini_set('soap.wsdl_cache_enabled', 1);

To enable cache for 2 mins

ini_set('soap.wsdl_cache_ttl', 120);