Bug With Imagemagick - Captcha

I don’t know where to put this. On a hostrocket shared hosting account the captcha suddenly stopped working. We were initially running 1.13, then tried 1.14 with no avail.


Fatal error: Out of memory (allocated 8650752) (tried t= o allocate 122880 bytes) in…

The script would stall out at some random spot. The server has 256M of memory allocated to php, verified. Further inspection of the logs showed this error:

libgomp: Thread= creation failed: Resource temporarily unavailable

Googling suggested that I set the MAGICK_THREAD_LIMIT to 1 using putenv. This did not work. I also tried to force it to use ‘gd’ as the backend using that property of captchaAction.

I haven’t compared code yet from 1.12 to 1.13 to see what changed. I solved the problem by downgrading back to 1.12 but I’m still looking for an answer.

I know it is not the best solution but you could go with 1.14 (to use new features, bug fixes, improvements, etc) and extract old captcha widget/action from 1.12 to your project directory structure and use them in your project instead of those provided by 1.14 framework.