bower/jquery/dist directory doesn't exist?!

Hi everyone,

I’m searching for a few hours about this issue, but still, this is everything I get:

The file or directory to be published does not exist: /app/vendor/bower/jquery/dist

I’m using Heroku and I’m not sure why this happens. I have also another Heroku project installed and everything is perfect.

I’ve found a few discussions on GitHub and tried everything but nothing happened.

My composer version is the latest. Fxp/composer-assets too.

Anyway, the irony is that there is a folder /app/vonder/bower/jquery/dist. Also there’s a folder bower-assets (in vendor).

Furthermore, I’ve tried with clearing the cache.


See if @vendor/autoload.php and the corresponding autoload_real.php are ok

They’re fine.

Here are GitHub discussions I’ve followed.

Is there anything else?

This is really bad. Never happened to me.

Here’s the solution for who might be interested in the future. Just remove fxp composer from your composer.json.

That’s it. Cheers.