Authentification Problems On Linux Machine

Hi everyone

I have an issue when transferring a finished Yii-application to a linux server from a windows machine. The application works fine on windows (and also on team member’s OSX). For some reason i don’t see some of the elements (links) in the navbar on linux. When entering the direct URL I get a 403 insufficient rights error.

I assume it has something to do with the Yii::app()->user->checkAccess() method which fails to grant me access.

When I modify the method checkAccess in CWebUser.php to return true instead of $access the application works fine except of some missing navbar elements (direct URL works then).

Any solutions, ideas or suggestions are appreciated. Thanks in advance.

My setup:

Windows machine:

Windows 7, XAMPP, PHP 5.4.4, PHP 5.3.15


Ubuntu 12.04.02, Apache 2.2.22, MySQL 5.5.31, PHP 5.3.10

Hey guys

I got it fixed but I’m not really sure what the issue was. I installed Ubuntu and other essential tools on my old laptop and it just worked. Then I transferred the application folder to the server and it also worked. The only difference to the old configuration is the newer Yii-version (1.1.13 instead of 1.1.12).

thx, solved