Assets error on a yii clone site [SOLVED]

Hi :

I’ve clone a yii site to get working another site :

-original :

-clone :

I cant find where is the problem with the extensions, the application can’t find the styles or libraries, the menu and the yii tabs aren’t load, maybe something in the routes.

I clean the assets directory but this don’t work.

In the applicattion log all errors are similar :

Unable to resolve the request “assets/d97af739/menu_blue.css”.’ in /var/www/vhosts/

Maybe is something related to the production o development enviroment, the application doesn’t load all the resources


I see two possible reasons:

  • The asset folder is not writeable for the webserver (but this should throw an exception i think). Check if there are files published, when you request some Yii pages.

  • If the files exist in the asset folder something’s wrong with your mod_rewrite setup: These requests should never be rewritten to Yii but handled by the webserver directly. So also double check your .htaccess.

Thanks Mike :

the asset folder creates the directories but these ones are empty, no files are copied to the folders.

Update : [SOLVED] after delete, create y change permissions of assets folder, now everything works, thanks mike

Hmm, could it be that safe mode is enabled on that server? Check this other thread, where balrok describes some problems:

Never had to deal with it, so can’t tell if that’s really the issue. You can find out with a call to phpinfo() in a simple testscript.

Yes Mike, I look "safe mode" in server and I have to disable too.

Glad to hear that!

The site looks much better now…