Am I stuck with /web/ in the URL bar or is there a way to remove this?

I can’t seem to find anything substantive on this issue, it does seem to be a genuine issue within Yii 2 to not be able to disable it easily enough. Have I missed something?

Yep, and there are a lot of resources showing how to deal with it.

If you are using apache, you setup a virtualHost and set the document root to /web.