AJAX Submit Not Working for CActiveForm

Is anyone else having a problem with a CActiveForm submitting normally, rather than via AJAX?

All the other great features of the form are working, using AJAX calls. The submit, however, is not. I am using CHtml::submitButton(). In the “Help Test CActiveForm” thread Quiang suggests clearing assets and says that the CHtml::ajaxSubmitButton() should not be necessary, but I am stuck. (I’ve tried the latter, which submits via ajax, but circumvents the CActiveForm functionality.

Thanks for any assistance. I posted my form on the last page of the "Help Test CActiveForm" thread.

Yeah, actually i miss that feature too :). I tried a lot but ended up using my custom javascript again, instead of CActiveForm. To be honest i’m not sure, if this can be integrated with the current implementation.

Main problem i see, is that CActiveForm always expects a validation result as response. But the situation is different when submitting. There can be two conditions:

  1. Validation was unsuccessful. So validation result must be sent to the client, as usual.

  2. Validation was successful. We can save the form data, but what should be sent back to the client? And what should the client do then?