Admin.php Grid Doesn't Get Loaded

Hi Guys,

I would like to get a little help, I hope somebody can help me out.

I have an admin page, that’s simply not fully loaded. navbar isn’t loaded, loading stops at advanced search (there is no CSS at all either). at index.php data is loaded and everything is shown correctly. I don’t really have any major customization in giix generated code. There are 32.000 records in the db table, and I would like to retrieve data through a standard search method. all the relations are alive, I’ve checked it, however I’ve messed a little bit with relations, because I had to fill up the table a few times after truncating, and because of truncating I had to disconnect relations. But I have put everything back so it should be good. I’ve tried to check the situation with firebug, but I can’t see anything. there is no valuable information in it, or, it’s just me who doesn’t know where to look exactly.

what can be wrong? Is it possible that the problem is with relations? what can I do?

thanks a lot!



Are you using the bootstrap extension? There is a comma missing in the _search.php file.

yes, I’m using it, I check it, thanks a lot!

yes, but I just use it in admin.php only for the grid, nothing else (everything else is giix standard generated stuff), and the exact same code works everywhere else, that’s why it’s weird for me.

UPDATE: I’ve deleted the whole search div from the page now I got this:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate

64 bytes) in ...\framework\db\ar\CActiveRecord.php on line 1799

why is that? is it too much records for yii? or should I adjust allowed memory usage for php?

I have found a relevant thread, but unfortunately nobody really knows what the problem is.

I have raised php memory limit in php.ini:

memory_limit = 256M

now the page is shown correctly.