Design of new action parameter feature

Ok, and this?




public function actionCreate($intCategory, $stringLanguage='en') { ...}



And then use the Reflection (getParameters, wich returns a ReflectionParameter object, and use getName) over the parameters, take the first part and do the cast?

Pros:

is DRY

follow our naming convention (Camel Case)

avoid comments (which can be stipped out)

Cons:

ugly name

put any others you see…

Thank you for your feedback.

Because the typecasting feature looks trivial and many people are opposing the existing solutions, we removed it from trunk.